wctob - wide-character to single-byte conversion
#include <stdio.h> #include <wchar.h> int wctob(wint_t c);
The wctob() function determines whether c corresponds to a member of the extended character set whose character representation is a single byte when in the initial shift state.
The behavior of this function is affected by the LC_CTYPE category of the current locale. See environ(5)
The wctob() function returns EOF if c does not correspond to a character with length one in the initial shift state. Otherwise, it returns the single-byte representation of that character.
See attributes(5) for descriptions of the following attributes:
|
btowc(3C), setlocale(3C), attributes(5), environ(5), standards(5)
The wctob() function can be used safely in multithreaded applications, as long as setlocale(3C) is not being called to change the locale.
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |