librt, libposix4 - POSIX.1b Realtime Extensions library
cc [ flag... ] file... -lrt [ library... ]
Historically, functions in this library provided many of the interfaces specified by the POSIX.1b Realtime Extension. See standards(5). This functionality now resides in libc(3LIB).
This library is maintained to provide backward compatibility for both runtime and compilation environments. The shared object is implemented as a filter on libc.so.1. New application development need not specify -lrt.
The shared objects librt.so.1 and libposix4.so.1 provide the public interfaces defined below. See Intro(3) for additional information on shared object interfaces.
aio_cancel | aio_error |
aio_fsync | aio_read |
aio_return | |
aio_waitn | |
clock_getres | |
clock_nanosleep | |
close | |
fork | |
mq_close | |
mq_notify | |
mq_receive | |
mq_reltimedsend_np | |
mq_setattr | |
mq_timedsend | |
nanosleep | |
sched_get_priority_min | |
sched_getscheduler | |
sched_setparam | |
sched_yield | |
sem_destroy | |
sem_init | |
sem_post | |
sem_timedwait | |
sem_unlink | |
shm_open | |
sigqueue | |
sigwaitinfo | |
timer_delete | |
timer_gettime |
The following interfaces are unique to the 32-bit version of this library:
aio_cancel64 | aio_error64 |
aio_fsync64 | aio_read64 |
aio_return64 | |
aio_waitn64 | |
lio_listio64 |
/lib/librt.so.1
/lib/64/librt.so.1
/lib/libposix4.so.1
/lib/64/libposix4.so.1
See attributes(5) for descriptions of the following attributes:
|
pvs(1), Intro(3), libc(3LIB), attributes(5), standards(5)
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |