libpthread - POSIX threads library
cc -mt [ flag... ] file... -lpthread [ -lrt library... ]
Historically, functions in this library provided POSIX threading support. See standards(5). This functionality now resides in libc(3LIB).
This library is maintained to provide backward compatibility for both runtime and compilation environments. The shared object is implemented as a filter on libc.so.1. New application development needs to specify -lpthread only to obtain POSIX semantics for fork(2) that assumes the behavior of fork1(2) rather than the default behavior that forks all threads.
The shared object libpthread.so.1 provides the public interfaces defined below. See Intro(3) for additional information on shared object interfaces.
__pthread_cleanup_pop | __pthread_cleanup_push |
pthread_attr_destroy | pthread_attr_getdetachstate |
pthread_attr_getguardsize | |
pthread_attr_getschedparam | |
pthread_attr_getscope | |
pthread_attr_getstacksize | |
pthread_attr_setdetachstate | |
pthread_attr_setinheritsched | |
pthread_attr_setschedpolicy | |
pthread_attr_setstackaddr | |
pthread_cancel | |
pthread_cond_destroy | |
pthread_cond_reltimedwait_np | |
pthread_cond_timedwait | |
pthread_condattr_destroy | |
pthread_condattr_init | |
pthread_create | |
pthread_equal | |
pthread_getconcurrency | |
pthread_getspecific | |
pthread_key_create | |
pthread_kill | |
pthread_mutex_destroy | |
pthread_mutex_init | |
pthread_mutex_setprioceiling | |
pthread_mutex_unlock | |
pthread_mutexattr_getprioceiling | |
pthread_mutexattr_getpshared | |
pthread_mutexattr_gettype | |
pthread_mutexattr_setprioceiling | |
pthread_mutexattr_setpshared | |
pthread_mutexattr_settype | |
pthread_rwlock_destroy | |
pthread_rwlock_rdlock | |
pthread_rwlock_trywrlock | |
pthread_rwlock_wrlock | |
pthread_rwlockattr_getpshared | |
pthread_rwlockattr_setpshared | |
pthread_setcancelstate | |
pthread_setconcurrency | |
pthread_setspecific | |
pthread_testcancel |
/lib/libpthread.so.1
/lib/64/libpthread.so.1
See attributes(5) for descriptions of the following attributes:
|
pvs(1), Intro(2), Intro(3), libc(3LIB), libc_db(3LIB), libthread(3LIB), attributes(5), standards(5), threads(5)
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |