libcontract - contract management library
cc [ flag... ] `getconf LFS_CFLAGS` file... -lcontract [ library... ] #include <libcontract.h>
Functions in this library provide various interfaces to interact with the contract(4) file system. The header provides structure and function declarations for all library interfaces.
The shared object libcontract.so.1 provides the public interfaces defined below. See Intro(3) for additional information on shared object interfaces.
ct_ctl_abandon | ct_ctl_ack |
ct_ctl_adopt | ct_ctl_nack |
ct_ctl_newct | |
ct_dev_status_get_aset | |
ct_dev_status_get_minor | |
ct_dev_tmpl_clear_noneg | |
ct_dev_tmpl_get_minor | |
ct_dev_tmpl_set_aset | |
ct_dev_tmpl_set_noneg | |
ct_event_get_ctid | |
ct_event_get_flags | |
ct_event_get_newct | |
ct_event_read | |
ct_event_reliable | |
ct_pr_event_get_exitstatus | |
ct_pr_event_get_pcorefile | |
ct_pr_event_get_ppid | |
ct_pr_event_get_senderct | |
ct_pr_event_get_zcorefile | |
ct_pr_status_get_fatal | |
ct_pr_status_get_param | |
ct_pr_status_get_creator | |
ct_pr_status_get_fmri | |
ct_pr_tmpl_get_param | |
ct_pr_tmpl_set_fatal | |
ct_pr_tmpl_set_transfer | |
ct_status_get_cookie | |
ct_status_get_holder | |
ct_status_get_informative | |
ct_status_get_nevid | |
ct_status_get_qtime | |
ct_status_get_type | |
ct_status_read | |
ct_tmpl_clear | |
ct_tmpl_get_cookie | |
ct_tmpl_get_informative | |
ct_tmpl_get_svc_fmri | |
ct_tmpl_set_critical | |
ct_tmpl_set_svc_aux |
/usr/lib/libcontract.so.1
/usr/lib/64/libcontract.so.1
See attributes(5) for descriptions of the following attributes:
|
pvs(1), Intro(3), contract(4), attributes(5), lfcompile(5)
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |