libc - C library
Functions in this library provide various facilities defined by System V, ANSI C, POSIX, and so on. See standards(5). In addition, those facilities previously defined in the internationalization and the wide-character libraries are now defined in this library, as are the facilities previously defined in the multithreading libraries, libthread and libpthread.
The shared object libc.so.1 provides the public interfaces defined below. See Intro(3) for additional information on shared object interfaces.
____loc1 | ___errno |
__builtin_alloca | __ctype |
__fbufsize | |
__flt_rounds | |
__fpurge | |
__freading | |
__fwritable | |
__huge_val | |
__loc1 | |
__makedev | |
__nsw_extended_action | |
__nsw_getconfig | |
__posix_ctime_r | |
__posix_getgrnam_r | |
__posix_getpwnam_r | |
__posix_sigwait | |
__priocntl | |
__pthread_cleanup_pop | |
__sysconf_xpg5 | |
__xpg4_putmsg | |
_Exit | |
_assert | |
_ctype | |
_environ | |
_exithandle | |
_flsbuf | |
_getdate_err | |
_iob | |
_isnand | |
_lwp_cond_reltimedwait | |
_lwp_cond_timedwait | |
_lwp_continue | |
_lwp_kill | |
_lwp_mutex_trylock | |
_lwp_self | |
_lwp_sema_post | |
_lwp_sema_wait | |
_lwp_suspend2 | |
_nextafter | |
_nss_XbyY_buf_alloc | |
_nss_netdb_aliases | |
_scalb | |
_sobuf | |
_sys_buslist | |
_sys_fpelist | |
_sys_segvlist | |
_sys_siglist | |
_sys_siglistp | |
_timezone | |
_toupper | |
_xftw | |
a64l | |
abs | |
acct | |
addrtosymstr | |
addseverity | |
aio_cancel | |
aio_fsync | |
aio_return | |
aio_waitn | |
aiocancel | |
aiowait | |
alarm | |
altzone | |
asctime | |
atexit | |
atoi | |
atoll | |
atomic_add_16_nv | |
atomic_add_32_nv | |
atomic_add_64_nv | |
atomic_add_8_nv | |
atomic_add_char_nv | |
atomic_add_int_nv | |
atomic_add_long_nv | |
atomic_add_ptr_nv | |
atomic_add_short_nv | |
atomic_and_16_nv | |
atomic_and_32_nv | |
atomic_and_64_nv | |
atomic_and_8_nv | |
atomic_and_uchar_nv | |
atomic_and_uint_nv | |
atomic_and_ulong_nv | |
atomic_and_ushort_nv | |
atomic_cas_32 | |
atomic_cas_8 | |
atomic_cas_uchar | |
atomic_cas_ulong | |
atomic_clear_long_excl | |
atomic_dec_16_nv | |
atomic_dec_32_nv | |
atomic_dec_64_nv | |
atomic_dec_8_nv | |
atomic_dec_ptr_nv | |
atomic_dec_uchar_nv | |
atomic_dec_uint_nv | |
atomic_dec_ulong_nv | |
atomic_dec_ushort_nv | |
atomic_inc_16_nv | |
atomic_inc_32_nv | |
atomic_inc_64_nv | |
atomic_inc_8_nv | |
atomic_inc_ptr_nv | |
atomic_inc_uchar_nv | |
atomic_inc_uint_nv | |
atomic_inc_ulong_nv | |
atomic_inc_ushort_nv | |
atomic_or_16_nv | |
atomic_or_32_nv | |
atomic_or_64_nv | |
atomic_or_8_nv | |
atomic_or_uchar_nv | |
atomic_or_uint_nv | |
atomic_or_ulong_nv | |
atomic_or_ushort_nv | |
atomic_swap_16 | |
atomic_swap_64 | |
atomic_swap_ptr | |
atomic_swap_uint | |
atomic_swap_ushort | |
backtrace | |
backtrace_symbols_fd | |
bcmp | |
bindtextdomain | |
brk | |
bsearch | |
bzero | |
catclose | |
catopen | |
cfgetospeed | |
cfsetospeed | |
chdir | |
chown | |
clearerr | |
clock_getres | |
clock_nanosleep | |
close | |
closefrom | |
cond_broadcast | |
cond_init | |
cond_signal | |
cond_wait | |
creat | |
crypt_genhash_impl | |
crypt_gensalt_impl | |
csetlen | |
ctermid_r | |
ctime_r | |
daylight | |
dbm_close | |
dbm_error | |
dbm_firstkey | |
dbm_open | |
dcgettext | |
decimal_to_double | |
decimal_to_quadruple | |
dgettext | |
directio | |
dirname | |
dladdr | |
dlclose | |
dlerror | |
dlmopen | |
dlsym | |
door_bind | |
door_create | |
door_getparam | |
door_return | |
door_server_create | |
door_ucred | |
double_to_decimal | |
dup | |
econvert | |
enable_extended_FILE_stdio | |
encrypt | |
endnetgrent | |
endspent | |
endutent | |
environ | |
err | |
errx | |
euclen | |
execl | |
execlp | |
execve | |
exit | |
facl | |
fchdir | |
fchown | |
fchroot | |
fcntl | |
fcvt | |
fdetach | |
fdopen | |
fdwalk | |
ferror | |
ffs | |
fgetc | |
fgetgrent | |
fgetpos | |
fgetpwent_r | |
fgetspent | |
fgetwc | |
file_to_decimal | |
finite | |
fmtmsg | |
fopen | |
fork1 | |
forkallx | |
fpathconf | |
fpgetmask | |
fpgetsticky | |
fpsetmask | |
fpsetsticky | |
fputs | |
fputws | |
free | |
frexp | |
fseek | |
fsetattr | |
fsetpos | |
fstatat | |
fstatvfs | |
ftell | |
ftime | |
ftruncate | |
ftw | |
funlockfile | |
fwide | |
fwrite | |
gconvert | |
getacct | |
getc | |
getc_unlocked | |
getchar_unlocked | |
getcpuid | |
getdate | |
getdents | |
getegid | |
geteuid | |
getextmntent | |
getgrent | |
getgrgid | |
getgrnam | |
getgroups | |
gethostid | |
gethrtime | |
getisax | |
getloadavg | |
getlogin_r | |
getmntent | |
getnetgrent | |
getopt | |
getopt_long | |
getpagesize | |
getpass | |
getpeerucred | |
getpgid | |
getpid | |
getppid | |
getpriority | |
getpw | |
getpwent_r | |
getpwnam_r | |
getpwuid_r | |
getrlimit | |
gets | |
getspent | |
getspnam | |
getsubopt | |
gettext | |
gettxt | |
getusershell | |
getutent | |
getutline | |
getutmpx | |
getutxid | |
getvfsany | |
getvfsfile | |
getw | |
getwchar | |
getwidth | |
getzoneid | |
getzonenamebyid | |
globfree | |
gmtime_r | |
gsignal | |
hcreate | |
hsearch | |
iconv_close | |
imaxabs | |
index | |
initstate | |
insque | |
is_system_labeled | |
isaexec | |
isalpha | |
isastream | |
isblank | |
isdigit | |
isgraph | |
islower | |
isnand | |
isnumber | |
isprint | |
issetugid | |
isspecial | |
iswalnum | |
iswblank | |
iswctype | |
iswgraph | |
iswprint | |
iswspace | |
iswxdigit | |
jrand48 | |
killpg | |
labs | |
lchown | |
lcong48 | |
ldivide | |
lfind | |
link | |
llabs | |
lldiv | |
llseek | |
localeconv | |
localtime_r | |
logb | |
longjmp | |
lsearch | |
lshiftl | |
lsub | |
lzero | |
makecontext | |
malloc | |
mbrlen | |
mbsinit | |
mbstowcs | |
memalign | |
membar_enter | |
membar_producer | |
memchr | |
memcntl | |
meminfo | |
memset | |
mkdir | |
mknod | |
mktemp | |
mlock | |
mmap | |
modctl | |
modf | |
modutx | |
mount | |
mq_close | |
mq_notify | |
mq_receive | |
mq_reltimedsend_np | |
mq_setattr | |
mq_timedsend | |
mrand48 | |
msgget | |
msgrcv | |
msgsnd | |
munlock | |
munmap | |
mutex_destroy | |
mutex_lock | |
mutex_unlock | |
nextafter | |
nfs_getfh | |
ngettext | |
nl_langinfo | |
nss_default_finders | |
nss_endent | |
nss_search | |
ntp_adjtime | |
open | |
opendir | |
optarg | |
optind | |
p_online | |
pause | |
pcsample | |
pfmt | |
plock | |
popen | |
port_associate | |
port_dissociate | |
port_getn | |
port_sendn | |
posix_fallocate | |
posix_memalign | |
posix_openpt | |
posix_spawn_file_actions_addclose | |
posix_spawn_file_actions_addopen | |
posix_spawn_file_actions_init | |
posix_spawnattr_getflags | |
posix_spawnattr_getschedparam | |
posix_spawnattr_getsigdefault | |
posix_spawnattr_getsigmask | |
posix_spawnattr_setflags | |
posix_spawnattr_setschedparam | |
posix_spawnattr_setsigdefault | |
posix_spawnattr_setsigmask | |
pread | |
printstack | |
priocntlset | |
priv_allocset | |
priv_delset | |
priv_fillset | |
priv_getbyname | |
priv_getsetbyname | |
priv_gettext | |
priv_intersect | |
priv_isemptyset | |
priv_isfullset | |
priv_issubset | |
priv_set_to_str | |
priv_union | |
processor_info | |
pselect | |
pset_bind | |
pset_destroy | |
pset_getloadavg | |
pset_list | |
psiginfo | |
pthread_atfork | |
pthread_attr_getdetachstate | |
pthread_attr_getinheritsched | |
pthread_attr_getschedpolicy | |
pthread_attr_getstack | |
pthread_attr_getstacksize | |
pthread_attr_setdetachstate | |
pthread_attr_setinheritsched | |
pthread_attr_setschedpolicy | |
pthread_attr_setstack | |
pthread_attr_setstacksize | |
pthread_barrier_init | |
pthread_barrierattr_destroy | |
pthread_barrierattr_init | |
pthread_cancel | |
pthread_cond_destroy | |
pthread_cond_reltimedwait_np | |
pthread_cond_timedwait | |
pthread_condattr_destroy | |
pthread_condattr_getpshared | |
pthread_condattr_setclock | |
pthread_create | |
pthread_equal | |
pthread_getconcurrency | |
pthread_getspecific | |
pthread_key_create | |
pthread_key_delete | |
pthread_kill | |
pthread_mutex_destroy | |
pthread_mutex_init | |
pthread_mutex_reltimedlock_np | |
pthread_mutex_timedlock | |
pthread_mutex_unlock | |
pthread_mutexattr_getprioceiling | |
pthread_mutexattr_getpshared | |
pthread_mutexattr_gettype | |
pthread_mutexattr_setprioceiling | |
pthread_mutexattr_setpshared | |
pthread_mutexattr_settype | |
pthread_rwlock_destroy | |
pthread_rwlock_rdlock | |
pthread_rwlock_reltimedwrlock_np | |
pthread_rwlock_timedwrlock | |
pthread_rwlock_trywrlock | |
pthread_rwlock_wrlock | |
pthread_rwlockattr_getpshared | |
pthread_rwlockattr_setpshared | |
pthread_setcancelstate | |
pthread_setconcurrency | |
pthread_sigmask | |
pthread_setschedprio | |
pthread_spin_init | |
pthread_spin_trylock | |
pthread_testcancel | |
putacct | |
putc_unlocked | |
putchar_unlocked | |
putmsg | |
putpwent | |
putspent | |
pututxline | |
putwc | |
putws | |
qeconvert | |
qfconvert | |
qgconvert | |
qsort | |
raise | |
rand_r | |
rctl_walk | |
rctlblk_get_firing_time | |
rctlblk_get_global_flags | |
rctlblk_get_local_flags | |
rctlblk_get_recipient_pid | |
rctlblk_set_local_action | |
rctlblk_set_privilege | |
rctlblk_set_value | |
re_comp | |
read | |
readdir_r | |
readv | |
realpath | |
regcmp | |
regerror | |
regexec | |
remove | |
rename | |
resetmnttab | |
rewind | |
rindex | |
rw_rdlock | |
rw_tryrdlock | |
rw_unlock | |
rw_wrlock | |
rwlock_init | |
scalb | |
scanf | |
sched_get_priority_min | |
sched_getscheduler | |
sched_setparam | |
sched_yield | |
schedctl_init | |
schedctl_start | |
seconvert | |
seekdir | |
sem_close | |
sem_getvalue | |
sem_open | |
sem_reltimedwait_np | |
sem_trywait | |
sem_wait | |
sema_destroy | |
sema_init | |
sema_trywait | |
semctl | |
semids | |
semtimedop | |
setbuf | |
setbuffer | |
setcontext | |
setenv | |
setgid | |
setgroups | |
setitimer | |
setkey | |
setlinebuf | |
setlogmask | |
setpflags | |
setpgrp | |
setpriority | |
setrctl | |
setreuid | |
setsid | |
setstate | |
settimeofday | |
setusershell | |
setutent | |
setvbuf | |
sgconvert | |
shm_unlink | |
shmctl | |
shmget | |
sig2str | |
sigaddset | |
sigdelset | |
sigfillset | |
sighold | |
siginterrupt | |
siglongjmp | |
sigpause | |
sigprocmask | |
sigrelse | |
sigsend | |
sigset | |
sigstack | |
sigtimedwait | |
sigwaitinfo | |
sleep | |
sprintf | |
srand48 | |
sscanf | |
stack_getbounds | |
stack_setbounds | |
stat | |
statvfs | |
str2sig | |
strcat | |
strcmp | |
strcpy | |
strdup | |
strerror_r | |
strftime | |
strlcat | |
strlen | |
strncat | |
strncpy | |
strptime | |
strsep | |
strsignal | |
strstr | |
strtof | |
strtok | |
strtol | |
strtoll | |
strtoull | |
strtows | |
swab | |
swapctl | |
swscanf | |
sync | |
sysconf | |
sysinfo | |
system | |
tcflow | |
tcgetattr | |
tcgetsid | |
tcsetattr | |
tdelete | |
telldir | |
textdomain | |
thr_continue | |
thr_exit | |
thr_getprio | |
thr_join | |
thr_keycreate_once | |
thr_kill | |
thr_min_stack | |
thr_setconcurrency | |
thr_setspecific | |
thr_stksegment | |
thr_yield | |
timer_create | |
timer_getoverrun | |
timer_settime | |
times | |
tmpfile | |
tmpnam_r | |
tolower | |
towctrans | |
towupper | |
tsearch | |
ttyname_r | |
twalk | |
tzset | |
u8_textprep_str | |
uadmin | |
ualarm | |
uconv_u16tou8 | |
uconv_u32tou8 | |
uconv_u8tou32 | |
ucred_get | |
ucred_geteuid | |
ucred_getpflags | |
ucred_getprivset | |
ucred_getrgid | |
ucred_getsgid | |
ucred_getzoneid | |
ulckpwdf | |
ulltostr | |
umount | |
uname | |
ungetwc | |
unlinkat | |
unordered | |
updwtmp | |
usleep | |
utime | |
utmpname | |
uucopy | |
verr | |
vfork | |
vfprintf | |
vfwprintf | |
vhangup | |
vpfmt | |
vscanf | |
vsprintf | |
vswprintf | |
vsyslog | |
vwarnx | |
vwscanf | |
wait3 | |
waitid | |
walkcontext | |
warnx | |
wcrtomb | |
wcschr | |
wcscoll | |
wcscspn | |
wcslen | |
wcsncmp | |
wcspbrk | |
wcsrtombs | |
wcsstr | |
wcstof | |
wcstok | |
wcstold | |
wcstombs | |
wcstoull | |
wcswcs | |
wcsxfrm | |
wctomb | |
wctype | |
wmemchr | |
wmemcpy | |
wmemset | |
wordfree | |
wracct | |
writev | |
wscasecmp | |
wschr | |
wscol | |
wscpy | |
wsdup | |
wsncasecmp | |
wsncmp | |
wspbrk | |
wsrchr | |
wsspn | |
wstok | |
wstoll | |
wsxfrm |
The following interfaces are unique to the 32-bit version of this library:
__div64 | __mul64 |
__posix_readdir_r | __rem64 |
__udiv64 | |
_bufendtab | |
_s_fcntl | |
_xftw64 | |
aio_error64 | |
aio_read64 | |
aio_suspend64 | |
aio_write64 | |
fgetpos64 | |
freopen64 | |
fsetpos64 | |
fstatvfs64 | |
ftruncate64 | |
getdents64 | |
lio_listio64 | |
lseek64 | |
mkstemp64 | |
nftw64 | |
pread64 | |
pwrite64 | |
readdir64_r | |
s_ioctl | |
setrlimit64 | |
statvfs64 | |
sys_nerr | |
tmpfile64 |
The following interfaces are unique to the 32-bit SPARC version of this library:
.div | .mul |
.rem | .stret1 |
.stret2 | |
.stret8 | |
.umul | |
_Q_add | |
_Q_cmpe | |
_Q_dtoq | |
_Q_fge | |
_Q_fle | |
_Q_fne | |
_Q_lltoq | |
_Q_neg | |
_Q_qtoi | |
_Q_qtos | |
_Q_qtoull | |
_Q_stoq | |
_Q_ulltoq | |
__dtoll | |
__dtoull | |
__ftou | |
__umul64 |
The following interfaces are unique to the 32-bit x86 version of this library:
__fpstart | _fp_hw |
_fpstart | _fxstat |
_lxstat | |
_thr_errno_addr | |
_xstat |
The following interfaces are unique to the 64-bit SPARC version of this library:
_Qp_add | _Qp_cmp |
_Qp_cmpe | _Qp_div |
_Qp_dtoq | |
_Qp_fge | |
_Qp_fle | |
_Qp_fne | |
_Qp_mul | |
_Qp_qtod | |
_Qp_qtos | |
_Qp_qtoux | |
_Qp_sqrt | |
_Qp_sub | |
_Qp_uxtoq | |
__align_cpy_1 | |
__align_cpy_2 | |
__align_cpy_8 | |
__ftoul |
/lib/libc.so.1
/lib/64/libc.so.1
/lib/c_synonyms.so.1
/lib/64/c_synonyms.so.1
See attributes(5) for descriptions of the following attributes:
|
pvs(1), Intro(2), Intro(3), attributes(5), lf64(5), standards(5)
The synonyms compatibility library, c_synonyms.so.1, provides a mechanism to support old applications and libraries that were mistakenly built using now-obsolete synonym symbols from libc.
Before the advent of direct binding (-B direct) libc provided many functions with two names. For example, getpwent() and _getpwent(). These two names referred to exactly the same function in libc. The leading-underscore symbol was intended to be used by system libraries in order to avoid conflicting with an application that might define its own version of getpwent() with completely different semantics. Standard-conforming applications may not define and use function names with leading underscores.
Solaris system libraries are now built with direct binding. This means that a system library that calls getpwent() will bind directly to the instance of getpwent() in libc, even if the application to which it is linked defines a different getpwent() for its own use. The application binds to its instance of getpwent() and there is no resulting conflict. The direct binding mechanism is equally available to libraries not delivered with Solaris.
As a result of this evolution, most of the leading-underscore synonym symbols have been removed from libc. This means that applications that call these now-obsolete function names will cease to work. They will typically draw the error:
$ ./application ld.so.1: fatal: relocation error: symbol _getpwent: referenced symbol not found Killed
All of the old leading-underscore symbols have been copied to the synonyms compatibility library. This library simply redirects the calls to the non-underscore instances of the corresponding functions in libc. Use it as a pre-loaded object:
$ LD_PRELOAD=c_synonyms.so.1 ./application
The synonyms compatibility library is intended neither to enable the generation of applications that call the obsolete leading-underscore synonym functions, nor to endorse this particular programming practice.
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |