getipsecprotobyname, getipsecprotobynum - query IPsec protocols entries
cc -flag ... file ...-lnsl [ -library ... ] #include <netdb.h> int getipsecprotobyname(const char *proto_name
char *getipsecprotobynum(int proto_nump
Use the getipsecprotobyname() and getipsecprotobynum() functions to obtain the IPsec algorithm mappings that are defined by ipsecalgs(1M). You can also use the getipsecprotobyname() and getipsecprotobynum() functions in conjunction with getipsecalgbyname(3NSL) and getipsecalgbynum(3NSL) to obtain information about the supported IPsec algorithms. The IPsec algorithms and associated protocol name spaces are defined by RFC 2407.
getipsecprotobyname() takes as an argument the name of an IPsec protocol and returns its assigned protocol number. The character string returned by the getipsecprotobyname() function must be freed by the called when it is no longer needed.
getipsecprotobynum() takes as an argument a protocol number and returns the corresponding protocol name.
The following protocol numbers are pre-defined:
IPSEC_PROTO_ESP
IPSEC_PROTO_AH
proto_name
proto_num
The getipsecprotobyname() function returns a protocol number upon success, or -1 if the protocol specified does not exist.
The getipsecprotobynum() function returns a protocol name upon success, or the NULL value if the protocol number specified does not exist.
See attributes(5) for descriptions of the following attributes:
|
ipsecalgs(1M), getipsecalgbyname(3NSL), getipsecalgbyname(3NSL), attributes(5)
Piper, D. RFC 2407, The Internet IP Security Domain of Interpretation for ISAKMP. Network Working Group. November, 1998.
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |