btowc - single-byte to wide-character conversion
#include <stdio.h> #include <wchar.h> wint_t btowc(int c);
The btowc() function determines whether c constitutes a valid (one-byte) character in the initial shift state.
The behavior of this function is affected by the LC_CTYPE category of the current locale. See environ(5).
The btowc() function returns WEOF if c has the value EOF or if (unsigned char)c does not constitute a valid (one-byte) character in the initial shift state. Otherwise, it returns the wide-character representation of that character.
See attributes(5) for descriptions of the following attributes:
|
setlocale(3C), wctob(3C), attributes(5), environ(5), standards(5)
The btowc() function can be used safely in multithreaded applications, as long as setlocale(3C) is not being called to change the locale.
Закладки на сайте Проследить за страницей |
Created 1996-2024 by Maxim Chirkov Добавить, Поддержать, Вебмастеру |