Объединение двух каналов в один на Cisco (cisco link multilink ppp)
Ключевые слова: cisco, link, multilink, ppp, (найти похожие документы)
From: ВОЛКА <BOJIKA@mailru.com.>
Newsgroups: http://cisco.far.ru
Date: Mon, 20 Apr 2005 18:21:07 +0000 (UTC)
Subject: Объединение двух каналов в один на Cisco
Оригинал: http://cisco.far.ru/multilink.php
Задача состояла в следующем:
Две циски связаны двумя 2Mb каналами. Нужно получить один канал с
пропускной способностью 4Mb
Предложено решение:
использовать ppp multilink
Так как 2509 не подерживала interface multilink пришлось использовать
interface virtual-template, но это не отразилось на работе.
ppp multilink можно настроить:
2610
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
enable secret 5 *****
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
cns event-service server
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
process-max-time 200
!
interface Multilink1
ip address 192.168.10.2 255.255.255.0
no ip directed-broadcast
no cdp enable
ppp multilink
multilink-group 1
!
interface Ethernet0/0
ip address 10.254.4.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/2
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/3
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
login
!
!
no scheduler allocate
end
3640
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterC
!
enable secret 5 *****
!
!
!
!
!
ip subnet-zero
!
cns event-service server
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
!
!
interface Multilink1
ip address 192.168.10.1 255.255.255.0
no ip directed-broadcast
no cdp enable
ppp multilink
multilink-group 1
!
interface Ethernet0/0
ip address 10.254.4.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
clockrate 2000000
no cdp enable
ppp multilink
multilink-group 1
!
interface Serial0/1
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 2000000
no cdp enable
ppp multilink
multilink-group 1
!
interface Serial2/0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/2
no ip address
no ip directed-broadcast
shutdown
!
interface Serial2/3
no ip address
no ip directed-broadcast
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2
ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
logging synchronous
login
!
end
interface virtual-template ≈ interface multilink
2509
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
enable secret 5 *****
!
ip subnet-zero
multilink virtual-template 1
!
!
!
interface Ethernet0
ip address 10.254.5.1 255.255.255.0
no ip directed-broadcast
!
interface Virtual-Template1
ip address 192.168.10.1 255.255.255.0
no ip directed-broadcast
ppp multilink
!
interface Serial0
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
clockrate 2000000
pulse-time 3
no cdp enable
ppp multilink
!
interface Serial1
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 2000000
pulse-time 3
no cdp enable
ppp multilink
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2
!
!
line con 0
transport input none
line 1 8
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
logging synchronous
login
!
end
2610
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterA
!
enable secret 5 *****
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
cns event-service server
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
process-max-time 200
!
interface Multilink1
ip address 192.168.10.2 255.255.255.0
no ip directed-broadcast
no cdp enable
ppp multilink
multilink-group 1
!
interface Ethernet0/0
ip address 10.254.4.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0/2
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
interface Serial0/3
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
login
!
!
no scheduler allocate
end
2610
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 *****
!
!
!
!
!
memory-size iomem 10
ip subnet-zero
!
multilink virtual-template 1
cns event-service server
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
process-max-time 200
!
interface Ethernet0/0
ip address 10.254.5.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
shutdown
no fair-queue
ppp multilink
!
interface Serial0/1
no ip address
no ip directed-broadcast
encapsulation ppp
shutdown
no fair-queue
ppp multilink
!
interface Serial0/2
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
pulse-time 3
ppp multilink
!
interface Serial0/3
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
pulse-time 3
ppp multilink
!
interface Virtual-Template1
ip address 192.168.10.2 255.255.255.0
no ip directed-broadcast
ppp multilink
!
ip classless
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
logging synchronous
login
!
!
no scheduler allocate
end
2509
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterB
!
enable secret 5 *****
!
ip subnet-zero
multilink virtual-template 1
!
!
!
interface Ethernet0
ip address 10.254.5.1 255.255.255.0
no ip directed-broadcast
!
interface Virtual-Template1
ip address 192.168.10.1 255.255.255.0
no ip directed-broadcast
ppp multilink
!
interface Serial0
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no ip mroute-cache
no fair-queue
clockrate 2000000
pulse-time 3
no cdp enable
ppp multilink
!
interface Serial1
bandwidth 2048
no ip address
no ip directed-broadcast
encapsulation ppp
no fair-queue
clockrate 2000000
pulse-time 3
no cdp enable
ppp multilink
!
ip nat translation timeout never
ip nat translation tcp-timeout never
ip nat translation udp-timeout never
ip nat translation finrst-timeout never
ip nat translation syn-timeout never
ip nat translation dns-timeout never
ip nat translation icmp-timeout never
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.2
!
!
line con 0
transport input none
line 1 8
line aux 0
line vty 0 4
exec-timeout 0 0
password *****
logging synchronous
login
!
end
Copyright © 2001, ВОЛКА <BOJIKA@mailru.com.>
Last modified: 16.10.01 11:59:04
ICQ: 51908208